Deep Learning関係

自動運転 (Autonomous Driving, Autonomous Vehicle Control, etc.)

演習付き講義(MIT)

  • ブラウザで Deep Learning できる
    • ConvNetJS ← GPUサポートなし
    • Keras.js ← GPUサポートあり
  • DeepTesla
  • DeepTraffic

プリンストン大

  • DeepDriving
    • 今のところ、ビデオゲームが主なターゲット

TORCS 公式ホーム ここにも

要はレーシングカーのシミュレーター。キーボードやマウスのみならず、ジョイスティックなども使える。

PCでの自律運転も可能。←懇切丁寧っぽいチュートリアルあり

ここからダウンロード

$ sudo apt-get install libplib-dev
$ sudo apt-get install libopenal-dev
$ sudo apt-get install libalut-dev
$ sudo apt-get install libvorbis-dev
$ sudo apt-get install libxxf86vm-dev
$ sudo apt-get install libxmu-dev

$ wget -O torcs-1.3.7.tar.bz2 'https://osdn.net/frs/g_redir.php?m=netix&f=%2Ftorcs%2Fall-in-one%2F1.3.7%2Ftorcs-1.3.7.tar.bz2'
$ tar xjf torcs-1.3.7.tar.bz2
$ cd torcs-1.3.7
$ ./configure
$ make
$ sudo make install
$ sudo make datainstall

$ torcs

で遊べる。(remoteは不可)

公式ホームによれば、torcs shellを使った実行と使わない実行が可能らしい。

DeepDriving (プリンストン大)公式ホーム

これに沿って進めた。

$ sudo apt-get install libplib-dev
$ sudo apt-get install libopenal-dev
$ sudo apt-get install libalut-dev
$ sudo apt-get install libvorbis-dev
$ sudo apt-get install libxxf86vm-dev
$ sudo apt-get install libxmu-dev

$ wget http://deepdriving.cs.princeton.edu/DeepDrivingCode_v2.zip
$ unzip DeepDrivingCode_v2.zip
$ cd DeepDriving/torcs-1.3.6
$ ./configure
$ make
$ sudo make install
$ sudo make datainstall

$ cd ..
$ pushd /usr/local/share/games
$ sudo chown -R nagai:nagai torcs
$ sudo cd /usr/local/lib
$ sudo chown -R nagai:nagai torcs
$ popd

.bashrc に下記を追加

# for DeepDriving
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
export TORCS_BASE=/home/nagai/DeepDriving/DeepDriving/torcs-1.3.6
export MAKE_DEFAULT=$TORCS_BASE/Make-default.mk
$ cp -rp modified_tracks/* /usr/local/share/games/torcs/tracks/road/

↑これはシンボリック・リンクの方が節約になる

$ cd Caffe_driving
$ cp Makefile.config.example Makefile.config

Makefile.config を修正

CUSTOM_CXX := g++-4.6

# MATLAB_DIR := /usr/local/MATLAB/R2013a
$ make

$ make runtest

の際にどうしてもエラー終了してしまう。(コアダンプ)

ここにインストールに関する詳しい情報あり。

CUDA library ver. 6.5を推奨とあるのが気になる。一応試したが変化なし。今回は ver. 7.5 (cudnn 4)をインストールしていた環境からダウングレードしたのが気になる。まっさらな環境で再挑戦したい。sudo apt-get install nvidia-cuda-toolkit を試すのも一興か。


トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2017-02-16 (木) 03:32:18 (158d)